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SPECT’R LICENSE AGREEMENT

This user license agreement (the "AGREEMENT") is an agreement between you (individual or single entity)
and Binary Acoustic Technology, for the SPECT’R software (the "SOFTWARE") that is accompanying this
AGREEMENT. USE OF THIS PRODUCT CONSTITUES YOUR ACCEPTANCE OF THESE TERMS
AND CONDITIONS.

The SOFTWARE is the property of Binary Acoustic Technology and is protected by copyright laws and inter-
national copyright treaties. The SOFTWARE is not sold, it is licensed.

PRODUCT VERSION

If you accepts the terms and conditions of this AGREEMENT, you have certain rights and obligations as fol-
low:

YOU MAY:

1. Install and use up to two(2) copies the PRODUCT VERSION.
2. Use one or more copies of the PRODUCT VERSION in conjunction with one or more Binary Acous-
tic Technology ultrasonic or acoustic receiver products.

YOU MAY NOT:

1. Sublicense, rent or lease the PRODUCT VERSION or any portion of it.
2. Decompile, disassemble, reverse engineer or modify the PRODUCT VERSION or any portion of it.
3. Distribute copies of the PRODUCT VERSION without written consent from an authorized represen-
tative of Binary Acoustic Technology

TRANSFER OF LICENSE

You may transfer your license to another individual or single entity on a permanent basis provided
that you retain no copies and the recipient agrees to the terms of this Agreement. Notice must be given by you
to Binary Acoustic Technology that such a transfer has taken place.

WARRANTY DISCLAIMER

The SOFTWARE is supplied "AS IS". Binary Acoustic Technology disclaims all war-
ranties, expressed or implied, including, without limitation, the warranties of mer-
chantability and of fitness for any purpose. The user must assume the entire risk of
using the SOFTWARE.

DISCLAIMER OF DAMAGES

Binary Acoustic Technology assumes no liability for damages, direct or consequential,
which may result from the use of the SOFTWARE, even if Binary Acoustic Technol-
ogy has been advised of the possibility of such damages. Any liability of the seller will
be limited to refund the purchase price.



Chapter 1 : Installation

The SPECT’R package includes one SPECT’R CD-ROM
and this manual. The CD-ROM contains the SPECT’R soft-
ware distribution along with a setup function that uses the
Microsoft Windows installer.

1.1 : What you should have received

1.2 : New Installation

Place the CD-ROM in the drive. After a short delay the CD-
ROM window should open. If this does not happen, double-
click the CD-ROM symbol in the My Computer folder.

When the CD-ROM window appears double click the Setup
icon. This will bring up the Window Installer. Follow the
directions to complete the installation.

1.3 : Updating an Older Version

Follow the same procedure as described in the section 1.2.

For reasons of safety it is good practice to create a backup
of your previous data before proceeding.

It is also recommended to uninstall older versions of SPEC-
T’R before installing new versions.



Chapter 2 : Installing Device Drivers

All Binary Acoustic Technologies Acoustic and Ultrasonic
Receiver products are shipped with a device driver CD-
ROM. Please retain these even after installation.

The drivers are based on the “Plug and Play” model. To in-
stall a device driver you must first connect the receiver prod-
uct to the computer. If an existing device driver can be
found, no action will occur and the receiver is ready to use.
Otherwise, an installation wizard will appear instructing you
to place the Driver CD-ROM into the CD drive. When you
have finished loading the CD-ROM. Enable the wizard to
search the CD-ROM and it will automatically install the cor-
rect device driver.

If the device drivers do not load automatically, follow the
steps outlined in the next section, Updating Device Drivers.

2.1 : Plug and Play Installation

As of version 3.3 SPECT’R III supports new 64-bit operating
system drivers. Use the Windows device manager to update
the device drivers:

1) Click on Start=>Control Panel=>System and Security.
2) Find and click on “Device Manager”.

This will bring up the device manager as shown on the next
page.

2.2 : Updating Device Drivers



USB extender cables can be used to increase the cable length
up to eighty feet. All binary acoustic technology receivers
require USB 2.0 compliant active extender cables.

The recommended procedure for connecting extended ca-
bling is to add only one extender cable at a time starting at
the computer and only connect the receiver after all the ex-
tenders have been connected. Note: in certain circumstances
the driver may need to be reloaded when using extension ca-
bles. In this case, an installation wizard will appear. Follow
the directions as per section 2.1.

2.3 : Using USB extender cables

Plug the AR125 into the computer
and then find the AR125 entry on
the Device Manager window.
There are three places that it can
appear. First, if no drivers are cur-
rently loaded on the computer then
it will appear under “Other De-
vices”. Second, if the original driv-
ers are installed then it will appear
under “Universal Serial Bus Con-
trollers”. Third, if 64-bit drivers
are installed then it will appear un-
der libusb-win32 devices.

To update the drivers, right-click on
the AR125 entry and select “update
driver software…”. Insert the BAT
driver CD and browse for the “AR
Installer” directory. Click Next to
update the drivers.



Chapter 3 : Running SPECT’R

3.1 : Running from desktop

A desktop icon is created and placed on
your desktop during the install.

You can start SPECT’R from the desktop
by double clicking on the SPECT’R icon
illustrated by Figure 1.

Figure 1: SPECT’R Icon

3.2 : Running from Start Menu

SPECT’R can also be run from the Start menu. You can run it
by selecting Start => All Programs => Binary Acoustic Tech-
nology => SPECTR. III

3.3 : Exiting

There are two ways to exit the program. The first is using the
red ‘X’ button in the upper right corner of the window. The
other way is using the File => Exit menu item.



3.4 : The Main Window

Version 3 of SPECT’R includes several major improvements in-
cluding increased range and a file compressor to save disk
space. The user interface has also be redesigned to improve
ease of use and several of the windows have been either redes-
igned or have important new features added.

Upon startup only the main window appears. The main window
has four primary sections. The control section (left) controls
the basic software and operation settings. The sonogram sec-
tion (center) displays a two dimensional real-time frequency vs.
time plot. The readout section (bottom) displays frequency and
time measurements. Finally the tuning section (right) is the pri-
mary mechanism for tuning the detector.

Figure 2: SPECT’R Main Window Layout

Note that SPECT’R is only dependent on having the receiver
present when it is actively recording. Otherwise the receiver
may be connected or disconnected at any time. The trace and
raster displays are only active when the receiver is connected
or during playback.



3.4.1 : Main Screen Control Section

Starting at the top of Figure 3 and
working down, the control section is
made up of a menu bar; a device in-
dicator; a response selection indica-
tor, a record mode indicator; a record
file selector; record and stop buttons;
an audio volume control slider along
with an audio level indicator; and a
brightness and contrast sliders.
Each of these will be described in de-
tail in the sections which follow.

Figure 3 : Control Section3.4.1.1 : Device Indicator

The device indicator displays either the receiver model that is
connected or “No device detected” in the case that a receiver has
not been detected.

3.4.1.3 : Response Mode Indicator

The response mode indicator displays the current response setting
and can either be “Natural” for uncompensated recording, or
“Compensated (Flat)” for recording digitally “flattened” files.

3.4.1.2 : Record Mode Indicator

The record mode indicator displays the record mode setting and
can either be “Audio” for audio bandwidth recording, “Full BW”
for full receiver bandwidth recording, or AutoSnap for automated
snapshot recording.



3.4.1.4 : Record File Selector

The record file select allows the operator to specify the filename
of the file to record. Clicking on the File… buttons brings up a
standard windows file selection tool, Figure 4, which allows the
operator to browse existing folders (or create new folders) and
specify a file name.

Important note on naming conventions. SPECT’R treats file-
names which end in numeric characters (‘0’ - ‘9’) specially. Each
time a recording is completed. SPECT’R will automatically in-
crement the file name to allow sequences of recording to be made
without having to reenter a new filename. The number of digits
will increase as required (i.e. ‘9’ => ‘10’) but it is best to use a
double or triple digit naming convention. In addition, the file
name selected in AutoSnap mode only specifies the base file
name. AutoSnap automatically appends a date and time-stamp.

Examples: test1, audio01, or fullbw00.

Figure 4: File selection tool



3.4.1.5 : Record and Stop buttons

The Record and Stop buttons control the recording process. The
buttons become active only when they are ready to be used. For
example when SPECT’R is first activated both record and stop
buttons are inactive (“grayed out”). The first to be activated is the
record button. It will only be activated when a file name is se-
lected and either of the following conditions; 1) the record mode
is audio and the operator selects a tuning range, or 2) the record
mode is either full bandwidth or AutoSnap. The stop button only
becomes active while SPECT’R is recording.

3.4.1.6 : Volume Control Slider

The volume control slider controls the volume of the audio level
for both the live audio monitor and the audio recording level if the
record mode is audio. If the record mode is full bandwidth, the
volume control slider only controls the live audio monitor.

The volume control slider can also be used to enable and disable
audio processing. When the slider is moved all the way to the
left, the audio processing is disabled.

The off position is when the slider is all the way to the left and
the maximum level is when the slider is all the way to the right.

3.4.1.7 : Audio Level Indicator

The audio level indicator measures the audio power level in dB
and displays it in a bar graph. Like the volume control slider,
minimum value is to the left, maximum value is to the right.



3.4.1.8 : Brightness and Contrast Controls

Simply stated, the Brightness and Contrast controls allow the op-
erator to adjust the screen appearance. Moving either slider left
reduces the screen brightness/contrast, while moving the slider
right increase the screen brightness/contrast.

To be more precise, the Brightness and Contrast controls actually
control how the underlying sonographic data maps to the screen
color and/or intensity. Explained this way, the brightness and
contrast actual control the level of sonographic detail that will be
mapped to the screen. The brightness control actually establishes
the mean value of the display, while the contrast controls the lin-
ear range or sensitivity around the mean value.

Once you master operation of the brightness and intensity con-
trols, you will find them a great tool to use to discover the subtle
details of bat vocalizations.

3.4.1.9 : Additional SonoSCOPE controls

In addition to the brightness and contrast sliders, SonoSCOPE has
several other controls. These controls are accessed by bring up an
independent control window. This window is described in the
next section.



3.4.2 : SonoSCOPE Control Window

To access the control window use the
menu and select Window => Sono-
SCOPE. The window shown in Figure
5 will appear.

Starting at the top and working down,
the control window is made up of a
pause button; a threshold control
slider; a detail selection slider; a di-
vision selection slider; and two fre-
quency Marker controls. Each of
these will be described in detail in the
sections which follow.

Figure 5 : SonoSCOPE
Control Window

3.4.2.1 : Pause Button

The pause button allows the operator to pause and resume the
sonogram. Pressing the button once will pause the sonogram, in-
hibiting further updates and allow the operator to make measure-
ments. Pressing the button again will resume normal sonogram
operation.

3.4.2.2 : Threshold Control Slider

The Threshold Slider controls the trigger threshold setting. The
threshold establishes the signal pressure required to trigger the
SonoSCOPE. The higher the threshold, the more selective the
triggering will be. Moving the slider to the left decreases the trig-
ger level. Moving the slider to the right increases the trigger
level.



3.4.2.4 : Division Selection Slider

The Division Control slider controls the number of divisions that
are placed on the sonogram display. The division control allows
the user to partition the display into sub-displays. Each time the
SonoSCOPE triggers it is only allowed to fill up a single division.
Divisions allow the operator to view the results of several trig-
gered events simultaneously. SonoSCOPE supports either one
(1), two (2), four(4), or eight (8) divisions across the display.
Moving the slider to the left decreases the number of divisions
across the sonogram, while moving the slider to the right in-
creases the number.

3.4.2.3 : Detail Selection Slider

The Detail selection slider allows the operator to adjust the time-
base of the sonogram in order to compress or expand the sono-
gram on the display. Higher detail generates a sonogram with a
finer time-base, but shorter duration. Lower detail generates a
sonogram with a courser time base but a longer duration. Moving
the slider to the left decreases the detail, while moving the slider
to the right increases the detail.



3.4.2.5 : Frequency Marker Controls

SonoSCOPE includes two frequency markers controls that place
frequency reference lines directly on top of the sonographic dis-
play. These are useful when you want to quickly distinguish bat
calls that are with in some specific frequency ranges. They can
also be used to make quick frequency measurements.

To enable a marker, click on the associated check box. To disable
it, re-click on the check box. Use the up and down buttons to
change the frequency of the marker. Alternately, you can change
the value by clicking in the edit box and entering the desired
value by hand.

Figure 6 : SonoSCOPE with frequency markers



3.4.3 : Spectral Trace Window

Bring up the Spectral Trace window by using the Windows =>
Spectral Trace… menu option. The Spectral Trace window is
primarily intended to provide a real-time view of the current
acoustic environment. The Spectral Trace window is configured
to measure frequency versus sound pressure level (SPL dB).
Use the mouse to move the cursor slowly over the trace section.
You will notice that the X(Hz), and Y(dB) readouts change as
the cursor moves. The X(Hz) readout displays the trace fre-
quency at the cursor position, while the Y(dB) readout display
the sound pressure level in decibels at that same cursor position.

The readout works in both standard and differential measure-
ment modes. To switch to differential mode, choose an audio
frequency/power-level reference by moving the cursor to a de-
sired position and left clicking the mouse. Two more readouts
will appear, dX(Hz) and dY(dB).

Figure 7 : Spectral Trace Window



3.5 : Tuning and Measurements

Tuning and Measurements are made using the sonogram dis-
play on the main window as shown in Figure 8.

The current tuning selection and tuning range are illustrated
by the green highlight and vertical blue line at the very right
of the sonogram display. The vertical blue line indicates the
current frequency selection and the green highlight indicates
the frequency band that is currently being translated.

To tune the heterodyne receiver., use the mouse or a Table
stylus to drag the highlighted region to the desired frequency
band.

Standard measurements of time, frequency, and power level
are made simply by moving the cursor to the point of inter-
est. You will notice that the readouts track the position of the
cursor when it is over the sonogram display. The readouts
will be updated to reflect the measurements at the current
cursor position.

Figure 8 : Sonogram Display



3.5.1 : Tuning and Measurement Example

Bring up the Sonogram control window by using the Windows
=> SonoSCOPE… menu option. Lower the trigger threshold to
fill up the display with triggered events and then press the pause
button. This freezes the display, so it will not be updated by any
other events. You are now ready to make measurements.

Take the mouse and move the cursor slowly over the Sono-
SCOPE display section. You will notice that the X(mSec), Y
(Hz) and Z(dB) readouts change at the cursor moves. The X
(mSec) readout displays the time, in milliseconds, at the cursor
position, the Y(Hz) readout displays the frequency at the cursor
position and the Y(dB) readout display the sound pressure level
in decibels at the cursor position.

Now choose reference point by moving the cursor to the desired
position and left clicking the mouse. Once the mouse is clicked,
three more readouts will appear, dX(mSec), dY(Hz) and dZ(dB).
Start moving the cursor around and you will notice that these
measure the difference between the current cursor position and
the position of the last mouse click (left click).



3.6 : Recording

SPECT’R incorporates a versatile recorder that allows the operator to
collect field data and store it directly on to a hard disk. The recorder
supports several different record modes, both manual long duration re-
cording and automated snapshot recording. It also includes an operation
timer that supports preprogramming SPECT’R to record during only
specific times each day. This supports long duration monitoring projects
and projects that require monitoring during only certain portions of each
day.

As of version 3.0.0, SPECT’R includes a built in file compressor. The
file compressor operates much like the popular zip utility. It saves disk
space by compressing the recordings as they are being recorded to disk.

3.6.1 : Selecting Recording Mode

The recording mode is selected us-
ing the Setup=>Record menu on
the main window. Bring up the
menu and click on the desired set-
ting. Three options are available,
Continuous, Automatic Snapshot,
and Buffered Snapshot.

Figure 9 : Record selection

Continuous is a continuous recording mode. The recorder starts when
the record button is selected and keeps recording until the stop button is
selected. Automatic Snapshot mode is not a continuous recording mode,
instead the recorder is voice activated and only records short duration
snapshots each time it detects activity. The recording starts when activ-
ity is detected. Buffered Snapshot mode is a manual record mode that
allows the operator to record a buffered segment which occurred just
prior to the operator pressing the record button. The length of the buff-
ered segment is controlled by the snapshot duration in the Record Setup
window.



The ideal sensor for collecting and recording bat calls has a completely
uniform response over the entire ultrasonic frequency range and, at the
same time, it offers high sensitivity with little thermal noise. As you
might imagine, real sensors don’t quite meet these ideal requirements.
However, there are methods to fix non-uniform response characteris-
tics to effectively generate a nearly ideal recording. SPECT’R in-
cludes such a method, a digital compensator.

The digital compensator is designed to flatten out the response of an
AR125 receiver such that the recording will have a nearly uniform re-
sponse over the 10KHz to 120KHz frequency range. This is especially
important for bat vocalization analysis. Also, digital compensation is
highly recommended for users who are using SonoBat to analyze
AR125 recordings.

SPECT’R provides two response options, Natural and Digitally Com-
pensated. If Natural response is selected, no compensation will be
performed. If Digitally Compensated is selected, then the compensa-
tor will be used to flatten out the response. To select an option, click
the appropriate option in the Setup => Response menu as shown by
figure 15.

3.6.2: Selecting the Response Characteristic

Figure 10 : Response selection



3.6.3 : Record Setup Window

The remaining recording settings both of the recording modes are
controlled using the record setup window as shown in Figure 11.
This window provides controls to configure both the Continuous
recorder, as well as the Buffered and Automatic Snapshot recorder.

Several of the controls are specific to the Buffered and Automatic
Snapshot recorder. These controls are the snapshot trigger con-
trols, the snapshot duration controls and the pop filter enable con-
trol. The remaining controls, the output format selector, the time
expansion factor selector and the comment field are common to
both recording methods.

Each of the controls will be described in detail in the sections
which follow.

Figure 11: Record Setup Window



3.6.4 : Snapshot specific controls

To enable Automated Snapshot recording and bring up the Record
Setup window, use the main menu to select
Setup=>Record=>AutoSnap.... This will bring up the window
as shown in Figure 11.

3.6.4.1 : Selecting trigger threshold

AutoSnap supports two different thresholding mechanisms, the first
is a manual fixed threshold and the second is automated variable
threshold based on the noise floor of the ultrasonic receiver. The
automated threshold is the default selection and is recommended
for most applications. However, the manual mode is available in
case the users have special triggering requirements.

Manual mode links the AutoSnap triggering mechanism to the
SonoSCOPE Threshold slider. This allows the operator to fine tune
the threshold setting using SonoSCOPE and then start the snapshot
recording using the same setting.

Automatic mode is not linked to SonoSCOPE. In automatic mode,
the snapshot generator monitors the input of the receiver and sets
the trigger threshold based on measurement of the receiver Noise
Floor (NF) along with the user specified threshold. For example, if
the threshold is set to 10 dB, then AutoSnap sets the trigger point
10 dB above the current receiver noise floor. This mode is quite
handy and works well in cases where the background noise changes
throughout the day. It’s primary advantage is that it avoids false
triggering problems due to changes in background noise.



3.6.4.2 : Selecting the trigger filter range

SPECT’R includes a versatile triggering filter which limits the fre-
quency range that is used to trigger snapshots. The default range is
18 KHz to 120 KHz. This range was chosen to inhibit triggering
due to human audible sounds like birds, frogs and geese.

The filter settings can be modified by the operator. To change the
range, click in one of the edit boxes and change the value.

3.6.4.3 : Selecting the snapshot duration

SPECT’R supports six different snapshot durations from one-tenth
of a second up to five seconds. The control panel includes a patch
of checkboxes that list the supported durations and allow the op-
erator to select a desired duration. To select the duration, simply
click on the checkbox next to the desired setting.

SPECT’R provides one custom duration option that can be modi-
fied by the operator. This allows SPECT’R to support non-
standard snapshot duration. To modify the custom duration, click
with in the duration edit box and enter the desired duration. The
setting will be saved and reused each time SPECT’R is used.

3.6.4.4 : The Idle Timeout option

The Idle Timeout option is a new feature which can be used to cre-
ate variable length files based on call activity. Enabling this option
tells the recorder to stop recording the current snapshot if no activ-
ity is detected for the specified time interval.

As an example, a common configuration is to set the snapshot du-
ration to 15 seconds and the idle timeout to 3 seconds. Each re-
cording will be a maximum of 15 seconds, but will terminate early
if no activity is detected over a 3 second interval.



3.6.5 : Common Recording Controls

The remainder of the recording setup window controls are shared
between the full bandwidth and automatic snapshot recorders

3.6.5.1 : Selecting the output format

SPECT’R supports two output formats, standard wave files
(*.wav) and compressed wave files using the open source
WAVPACK format. To record standard wave files select the Stan-
dard option. To record compressed wave files select the Com-
pressed option.

The compressed files are roughly one-third the size of standard
wave files and as such they save on disk space. WAVPACK was
chosen because it is a lossless compression technique and produces
superior results. WAVPACK is open source software and is li-
censes under the BSD Software License by Conifer Software.

Important note: all Binary Acoustic Technology software sup-
ports WAVPACK files. However, use the standard format if
you plan to analyze the recordings using SonoBat.

3.6.4.5 : Enabling the pop filter

In addition to the trigger filter range, SPECT’R includes a pop fil-
ter which is used to reject pop noise such as electrostatic noise and
certain bug noises. The pop filter is recommended for most appli-
cations. It significantly reduces the number of falsely triggered
snapshots and has been shown to have little or no impact on actual
bat calls.



3.6.5.3 : Entering a Comment

The Auto Snap Setup window includes a text editing box for com-
ments. Comments are useful because they allow the operator to
add collection details which will be placed into the files as they are
recorded. The comments can be read back and displayed on play-
back, giving important reference information about the original
collection.

The comment field is automatically updated during file playback
to allow comments to be propagated from a source file to any files
recorded from it.

To enter or edit a comment, simply click in the comment editing
box and type. The comment field is limited to 400 characters.

3.6.5.2 : Selecting the time expansion factor

SPECT’R is actually a real-time recorder and does not actually
need to time expand the data for recording purposes. The time ex-
pansion factor selector is included to make the recorded files com-
patible with existing analysis tools and multimedia players. Time
expansion is select by clicking on the desired setting. The default
time expansion is 10x.

Important note: Use the default time expansion factor of 10x, if
you plan to analyze the recordings using SonoBat.



3.6.7 : File Compatibility

SPECT’R generates industry standard wave file (*.wav) format
that can be read by both Windows and Mac based personal com-
puters. SPECT’R also adds recorder setting and operator com-
ments attributes to the files. These are inserted into the recordings
as they are created. The attributes are compatible with SonoBat.
This allows AutoSnap generated files to be read directly into Sono-
Bat without having to perform any formatting or setup operations,
which saves time and confusion.

SPECT’R also generates compressed wave file (*.wv) format as
specified and created by the WAVPACK audio compressor. All of
Binary Acoustic Technologies software products have been up-
dated to handle compressed wave files. There are also a number of
other audio processing tools and players that can read these files.
See www.wavpack.com for more details.

3.6.8 : Log File Generation

The snapshot recorder includes an activity logging function. As
the recorder is recording it automatically generates a log file. The
log file is useful in determining how the recorder was recording in
the event that the batteries ran out while performing a recording
session. The log file uses the same base file name as the snapshot,
but with “_DYYYYMMDD_log.txt” appended to the base name.
It is located in the same directory as the snapshots.



3.7 : Operation Timer

3.7.1 : Enabling the Operation Timer

To enable the Operation Timer, use the main menu to select Win-
dow=>Operation Timer... and the Operation Timer window shown
in Figure 12 will appear.

The Operation Timer window includes a current time indicator, a
status indicator, two record program sections and a power saver se-
lector. The window also include a power saving button that shuts
down the processing intensive portions of the software when it is not
actively recording. This conserves power and increases battery life.

The individual controls are described in the sections which follow.

Figure 12: Operation Timer

The operation timer is a new feature introduced in version 2.1.8. It
enhances the unattended operation capability of SPECT’R, allow-
ing the operator to specify the time windows that SPECT’R is al-
lowed to record. This allows the operator to leave the equipment
in the field for multiple days at a time. It also includes a power
saver feature that conserves CPU cycles and power when it is not
actively recording.



3.7.3 : Status Indicator

The status indicator displays the current status of the operation
timer.

3.7.2 : Current Time Indicator

The current time indicator is at the top of the Operator Timer
Window. It updates once per second to indicate the current
time. The time will be displayed either as Local time or Univer-
sal Coordinated Time (UTC), depending on the current setting
of SPECT’Rs Time Standard. For information on how to set the
Time Standard see section 3.9.1.

3.7.4 : Record Window Program Section

The Operation Timer window includes two record window pro-
gramming sections. Each section consists of start and stop
times, a file selector, and a comment box. The start and stop
times control the start and stop times of a recording session.
These values are interpreted as either Local or UTC times, de-
pending on the current Time Standard setting. The file selector
button brings up a windows file selection tool that allows the
operator to choose a file name that will be used for all files re-
corded during the time window specified. The program section
also includes a comment box. The contents of the comment box
will be written to all files recorded during the time window.

To program a record session, set the start and stop times, choose
a file by clicking on the File… button, enter the file comment in
the comment box. Once all this has been configured, click on
the Program check box to activate the program.



3.8 : Remote File Transfer

Figure 13: File Transfer window

As of version 3.3.1, SPECT’R III supports remote file transfer.
The remote file transfer feature enables a remote collection sys-
tem to automatically transfer snapshot recording back to a web-
accessible computer or FTP site. This allows a collection station
to be operated remotely without the need to send technicians
into the field to collect data.

In order to support remote file transfer the computer system run-
ning SPECT’R III must be outfitted for internet access using a
broadband access service or a cellular or satellite modem.



3.8.2 : Enabling File Transfer

To enable file transfer operations simply click on the Enable
File Transfer check box. When checked, file transfer opera-
tions are enabled.

3.8.1 : File Transfer Status Indicator

The status indicator displays the current status of the file transfer
engine. The status will be “InActive” while no SPECT’R III is
idle. It will indicate “Active” while SPECT’R III is operating in
any of the supported recording modes. It will also display the
progress of all file transfer operations.

3.8.3 : Limiting the transfer times

When using slower computers it may become necessary to limit
the file transfer times and only transfer files will SPECT’R III is
idle and in power save mode. To limit the transfer time, click on
the Transfer only during power save check box. When
checked, SPECT’R III will only transfer file during power save.
Note: when using this option be certain that the power save fea-
ture is also enabled in the operation timer.



3.8.4 : Configuring the file transfer location

In order to setup the file transfer location (the place to send the
files), you must know the web site address of the computer to
send the data to along with the directory in which the files will
be stored. To configure SPECT’R III to send the files, enter the
web site address in the FTP site edit box and enter the desired
directory in the FTP directory edit box.

The web addresses are usually of the form ftp.<sitename>.com
and the directory names follow the general UNIX standard path
name specifications, for example “/<top directory>/<sub direc-
tory.” If no directory is used, the FTP directory should be set
as either a single period character (‘.’) or a single forward slash
character (‘/’).

3.8.5 : Enabling Login Option

Most websites will require and username and password in order
to accept file transfers. To enable operation with usernames and
passwords click on the Login as option and enter the appropri-
ate username and password in to there respective edit boxes.

3.8.6 : Local Archive Option

By default, SPECT’R III will delete (send to recycle bin) all
files once they have been successfully transferred. If you wish
to keep a local copy then click on the Local Archive check box
and select an archive directory by clicking on the Browse but-
ton. Note: the archive directory must be unique and can not du-
plicate any of the snapshot directories.



3.8.7 : File Transfer Tips

1) It is highly recommended to use file compression when oper-
ating using remote file transfer. This significantly reduces
the link bandwidth and transfer time requirements. If you are
using SonoBat to analyze the file, you can always convert
them back into wav files using a the WAVPACK unpack
function.

2) When SPECT’R III deletes files, it actually sends them to the
recycle bin. To avoid filling up the recycle bin it is recom-
mended to configure the recycle bin to delete all files rather
than saving them. To do this, right click on the recycle bin
icon and choose properties. When the Recycle Bin Proper-
ties window appears, click on the Global tab and select the
Do no move file to the recycle bin. Remove file immediately
when deleted option. This will keep the disk from filling up
the recycle bin during extended duration operation.

3) When setting up the site name, directory, username, and
password, you can test it live by enabling snapshot recording
and generating a few snapshots. If any of the settings are
wrong the Status display will generate warnings. You can
edit the values while SPECT’R III is running until the status
indicates that files are being transferred properly

Important Note: the file transfer features only operates when the
operation timer is active (either program 1 or program 2 is en-
abled) or when the main snapshot recorder is active. If the
status indicator is “InActive”, then neither of the above condi-
tions is true.



3.9 : File Playback

3.9.1 : Enabling Playback

To enable the playback feature, select File=>Playback…and the
playback window shown in figure 13 will appear. SPECTR
only supports one input stream at a time. During playback any
ultrasonic receiver that is connected will be ignored and only the
playback function will be allowed to supply data. Once the
playback control window is dismissed, the ultrasonic receiver
will resume.

Figure 14: Playback window

3.9.2 : Exiting Playback

There are two ways to exit playback. The first is using the red
‘X’ button in the upper right corner of the playback control win-
dow. The other way is using the Exit button.



3.9.4 : Loop Selection

The Loop selection allows the same file to be played backed in
loop mode. When Loop is selected the file will be continuously
played back. If it is not selected, playback will automatically
stop at the end of the file.

3.9.5 : Play , Pause, and Stop Buttons

The Play, Pause and Stop buttons control the playback. Play
starts the playback. Pause stops the playback in its current posi-
tion allowing Play to resume from there. Stop stops the play-
back and resets it to the beginning of the file.

3.9.3 : Selecting File

To select the playback file. Select the File… button in the play-
back control window. This will bring up a file selection tool
similar to figure 4. Select the file of interest and press Open.

3.9.6 : Time Base Selection

One of the very powerful features of playback is its ability to
perform variable rate playback. This is commonly referred to as
“Time-Stretching”. The playback control window provides two
preset time base selections and a third user defined selection.
The two preset selections are 1:1 (normal speed) and 1:2 (half
speed). The variable selection is defaulted to 1:4 (one fourth
speed). While all the default selections are power-of-two ratios,
the variable rate selection can support any ratio (with in rea-
son!).



3.9.7 : Playback Comment Box

If the playback file contains a comment attribute, the comment
will be displayed immediately after the file is selected.

Editing this comment from the Playback feature has no effect
and the comments in the Playback box are NOT automatically
passed on to any files that are processed and recorded using
playback. To pass comments on, the comment must be high-
lighted and copied from the Playback comment box and then
pasted to the AutoSnap comment box.



3.10 : GPS Receiver Interface

3.10.1 : Enabling GPS Function

The GPS interface in SPECT’R III is fully automated. To en-
able it just plug in a compatible GPS receiver. The main re-
quirement for GPS receivers is that they must support the Gar-
min PVT, type 800, protocol. To check if SPECT’R III recog-
nizes the receiver click on Window=>GPS Status to bring up the
status window shown below.

The GPS receiver that SPECT’R III is tested against at the fac-
tory is the Garmin GPS18x USB.

Figure 15: GPS Status window

Starting from the top to
the bottom, the status
window displays the re-
ceiver information
string, the current loca-
tion, the receiver status,
and the GPS satellite
numbers that are cur-
rently in view.

When first plugged in it
takes a minute or so to
generate a location fix.
SPECT’R III will ignore
the receiver until it gen-
erates a valid GPS Fix.



4.0 : Basic Operations

SPECT’R can select between multiple
input receivers. This feature allows a
single laptop to operate multiple re-
ceivers at the same time. Each in-
stance of SPECT’R handles a single
receiver. Startup an additional copy of
SPECT’R for each additional receiver.

The input device is selected using the
Setup=>Device menu on the main
window. Bring up the menu and click
on the desired driver. The current
mode setting is displayed as a checked
menu option. The driver assignment
for the actual receivers is based on the
order that they were plugged in.

4.0.2 : Selecting Input Device

Figure 17 : Device selection

As of version 2.1.8, SPECT’R allows
the operator to select the time standard
used to time stamp the snapshot files.
SPECT’R supports either Local Time,
the current time zone selection of the
computer, or Universal Coordinated
Time (UTC) which is effectively
Greenwich mean time.

The time standard is selected using the
Setup=>Time Standard menu on the
main window. Bring up the menu and
click on the desired setting.

4.0.1 : Selecting the Time Standard

Figure 16 : Time Standard



SPECT’R provides two response options, Natural and Digitally
Compensated. If Natural response is selected, no compensation will
be performed. If Digitally Compensated is selected, then the com-
pensator will be used to flatten out the response. To select an option,
click the appropriate option in the Setup => Response menu as de-
scribed in section 3.6.2.

4.0.4: Selecting the Response Characteristic

The recording mode is selected using the Setup=>Record menu on
the main window. Bring up the menu and click on the desired set-
ting. The current mode setting is displayed as a checked menu op-
tion as described in section 3.6.1.

4.0.3: Selecting Recording Mode

Audio monitoring is performed using the SPECT’R heterodyne
detector. To operate the audio monitor, select the desired tuning
frequency by moving the cursor to the desired frequency in ei-
ther the trace or raster displays and left click the mouse. The se-
lected region will highlighted on the trace and audio will start
flowing.

Use the volume slider to adjust the audio output level to suit
your preferences. If no sound is present or if the levels are not
suitable you can adjust the computer system audio card by se-
lecting Start=>Control Panel=>Sound,Speech,and Audio De-
vices=>Adjust the System Volume.

4.0.5 : Audio Monitoring



Continuous mode records the entire receiver bandwidth to disk.
Continuous recordings are ideal because they contain the full
spectra and all the nuances of the original signals. They can ei-
ther be played back at normal rates and re-processed to generate
tuned audio cuts, or they can be played back at a reduced rate
(so called time-stretching) for an entirely different auditory ex-
perience. With time stretching the signals are played back in
slow motion and all the frequencies collapse down into the au-
dio frequency range. This preserves the nuances and harmonic
relationships of the original ultrasonic signal.

To select continuous recording mode use the setup menu as
shown in Figure 6. Select Setup=>Record=>Continuous... to
choose continuous recording. This will bring up the Record
Setup window and update the Recode Mode indicator in the
main window control section . Next, you must specify a file-
name as described in section 3.5.3. After the filename is se-
lected, the Record button will become active. Click on the Re-
cord button to start recording. Notice that the Record button de-
activates, but at the same time the Stop button activates. When
you are finished, click the Stop button and the recording will
complete.

A continuous recording can be stored as a time expanded file
and can also include comments. These features are controlled
from the Record Setup window.

In practice it is best to keep the recordings to a manageable size.
If a two or three digit number is added to the end of the file-
name, SPECT’R will automatically increment these digits each
time a record is stopped. This mechanism provides the operator
with an easy way to breakup the collection into a set of indexed
files. The operator only needs to stop and then restart the re-
cording periodically, every few minutes or so.

4.0.6 : Continuous Recording



Automatic Snapshot mode also records the entire receiver band-
width to disk, but it only records a short duration snapshot and it
only records when it detects activity. This is extremely useful
when performing field surveys over an extended time period.
The snapshot mode reduces disk space use and it reduces the ef-
fort required to go back and analyze the results. Like continu-
ous recordings, the Snapshot recordings can be played back and
processed to generate short audio cuts, however, they are pri-
marily intended for bat vocalization and identification analysis
using an analysis package like SCAN’R or SonoBat.

To select snapshot mode use the setup menu as shown in Figure
6. Select Setup=>Record=>Auto Snap.... This will bring up the
Record Setup window and update the Recode Mode indicator
in the control section . For now, leave the default settings but
enter a comment into the comment box. Next, you must specify
a filename as described in section 3.5.3. For AutoSnap it is rec-
ommended to employ a short filename, because AutoSnap will
automatically append a date and time stamp to your file name.
After the filename is selected, the Record button will become
active. Click on the Record button to enable recording. Notice
that the Record button deactivates, but at the same time the Stop
button activates. This action only arms the recorder. Snapshots
will be created only when activity is detected.

The Record Setup window includes a snapshot status indicator
near the bottom. This can be used to monitor recorder activity.
The statue indicator also displays the name of the most recently
recorded file and can be used to monitor snapshot activity.

To stop recording, click the Stop button and the recording ses-
sion will complete.

4.0.7 : Automatic Snapshot Recording



Buffered Snapshot mode also records the entire receiver bandwidth
to disk, but it only records short duration snapshots and it only re-
cords when the operator requests. Buffered mode is extremely
useful when performing attended field surveys. The buffered snap-
shot mode allows the operator to monitor bat vocal activity and
manually select specific recordings with interesting vocalization
segments. Like other recordings, the Buffered Snapshot recordings
can be played back and processed to generate short audio cuts,
however, they are primarily intended for bat vocalization and iden-
tification analysis using an analysis package like SCAN’R or Sono-
Bat.

To select buffered snapshot mode use the setup menu as shown in
Figure 6. Select Setup=>Record=>Buffered Snap.... This will
bring up the Record Setup window and update the Recode Mode
indicator in the control section . For now, leave the default set-
tings but enter a comment into the comment box. Next, you must
specify a filename as described in section 3.5.3. For Buffered
Snapshots it is recommended to employ a short filename, because
Buffered Snapshots will automatically be appended with a date and
time stamp to the end of your file name. After the filename is se-
lected, the Record button will become active. Click on the Record
button to selectively enable recording of each snapshot. Once the
Record button is pressed a recording will be made of the activity
that occurred just prior to the instant that the record button was
pressed. Notice that the Record button deactivates, but at the same
time the Stop button activates. The recording will be automatically
stopped after the recording is saved to disk. The duration of the
snapshot is controlled by the Snapshot Duration control

The benefit of Buffered snapshot is that the operator can actively
monitor bat activity and manually select interesting segments to re-
cord by pressing the record button at the end of an interesting bat
pass.

4.0.8 : Buffered Snapshot Recording



SonoSCOPE is a sonographic analyzer that is optimized for live
processing and bat identification. It uses a synchronized trigger-
ing mechanism that maintains visual alignment on the display, al-
lowing the operator to see events that actually occur faster than a
blink of the eye.

Bring up the SonoSCOPE control window using the main menu
bar, select Window=>SonoSCOPE…. Next, adjust the trigger
level by first sliding the threshold to the left until SonoSCOPE
begins triggering and then sliding it just slightly right to slow
down the triggering to a few per second. Next, set the number of
divisions across the screen using the division slider and then set
the level of detail using the detail slider. Note: the combination
of divisions and detail controls the time span displayed each time
SonoSCOPE triggers.. Finally, use the brightness and contrast
controls to set the display mapping to your preference.

To make measurements using the SonoSCOPE display, first click
on the PAUSE button to stop all updates. Then place the cursor
over any point in the sonogram and the readouts will display the
three dimensional position pointed to by the cursor. To make dif-
ferential measurements, click the mouse on the desired reference
position. This will be the reference point for all difference meas-
urements.

The current tuning selection and tuning range are illustrated by
the green highlight and vertical blue line at the very right of the
sonogram display. The vertical blue line indicates the current fre-
quency selection and the green highlight indicates the frequency
band that is currently being translated.

To tune the heterodyne receiver., use the mouse or a Table stylus
to drag the highlighted region to the desired frequency band.

4.0.9 : Running SonoSCOPE



The Playback function supports both full bandwidth and audio
bandwidth recordings. In fact, it will support any 16-bit
mono .wav formatted file. Stereo files are not supported and
will not playback correctly. Recordings can either be played
back at normal rates or they can be played back at variables
rates (time-stretching or time-compressing). For best time-
stretching results, it is best to use full bandwidth recordings.
This is because time-stretching causes higher frequencies, in-
cluding ultrasonic frequencies, to collapse down into the audio
frequency range. Time-stretching is less useful for audio re-
cordings, but you can still have fun experimenting with it.

To select playback mode use the file menu. Select
File=>Playback… and the playback control window will appear.
Select a file to playback by pressing the File… button and using
the Windows file selection tool to select a file. Choose the
playback time base and press the Play button to start playback.

While playback is running, the selected file will be imported
into the main SPECTR application. The main application will
function as if the file where the input of the ultrasonic receiver
allowing audio monitoring, audio recording and spectral analy-
sis.

4.0.10 : Playback



The Operation Timer supports all recording modes. Be certain
to select the appropriate record mode (section 3.9.3) prior to
enabling the operation timer.

Programming an operation requires three steps:

First, enter the desired start and stop times. All times are speci-
fied in the HH:MM:SS format. SPECT’R interprets these as ei-
ther Local cpu time or UTC time depending on the Time Stan-
dard setting (section 3.9.1).

Second, select a desired base file name and directory by clicking
on the File button. This will bring up a standard file selection
window. The file names follow SPECT’R standard file naming
conventions.

Third, enter a comment that will be used with all files recorded
during the program.

Once all three of the steps above are completed, you can activate
the program by clicking on the Program check box.

Note: the operation timer include a Power Saver mode. When
power saver mode is enabled SPECT’R disables it’s processing
flow which will save battery power, especially if your laptop
uses some of the new mobile CPU’s with speed step or other
low power use mode.

4.0.11 : Operation Timer



5.0 : Further Information

For further information or trouble shooting, please contact
us or visit our web site.

Web: www.binaryacoustictech.com
E-Mail : info@binaryacoustictech.com

For more information on SonoBat, visit www.sonobat.com.
For more information on WAVPACK, visit www.wavpack.com


